Σίγμα:



σειριακή αναζήτηση, σημασιολογία, σταθερά, στατική δομή δεδομένων, στοίβα, συγχώνευση, συμβολική γλώσσα, συμβολομεταφραστής, συνάρτηση, συνδέτης-φορτωτής, συνθήκη, συντάκτης, σφάλμα, SQL



Σειριακή αναζήτηση ή Γραμμική αναζήτηση: Μέθοδος αναζήτησης στοιχείο μέσα σε μια δομή δεδομένων, με προσπέλαση των κόμβων της δομής έναν προς έναν μέχρις ότου βρεθεί το στοιχείο. Χρησιμοποιείται για αταξινόμητα δεδομένα.

SEARCH.JPG
Σειριακή αναζήτηση στοιχείου που δεν υπάρχει στον πίνακα.

Παράδειγμα: Αλγόριθμος σειριακής αναζήτηση σε μονοδιάστατο πίνακα n στοιχείων, εκφρασμένος σε ψευδογλώσσα. Αν το ζητούμενο στοιχείο βρεθεί (found αληθής) τότε η τιμή της μεταβλητής position δηλώνει τη θέση του πίνακα που βρέθηκε.
Αλγόριθμος Σειριακή_Αναζήτηση
Δεδομένα //array, n, element//
found←ψευδής
posisiton←-1
i←1
Όσο (dound==ψευδής) και (i<=n)
    Αν array[i]==element τότε
        found←αληθής
        position←i
    αλλιώς
        i←i+1
    Τελος_αν
Τέλος_Επαναληψης
Αποτελέσματα //found, position//
Τέλος Σειριακή_Αναζήτηση
 




Σημασιολογία (Semantics): Το σύνολο των κανόνων που καθορίζει το νόημα των λέξεων, των εκφράσεων και των προτάσεων μιας γλώσσας.




Σταθερά (Constant): Γλωσσικό αντικείμενο, που δηλώνεται στο τμήμα δηλώσεων ενός προγράμματος, και αρχικοποιείτει παίρνοντας μία καθορισμένη σταθερή τιμή καθ'όλη τη διάρκεια εκτέλεσης του προγράμματος.

Παράδειγμα: Στη ΓΛΩΣΣΑ υποστηρίζονται 4 είδη σταθερών, ΑΚΕΡΑΙΕΣ, ΠΡΑΓΜΑΤΙΚΕΣ, ΛΟΓΙΚΕΣ και ΧΑΡΑΚΤΗΡΕΣ. Παράδειγμα δήλωσης σταθερών.

ΣΤΑΘΕΡΕΣ
   ΠΙ=3.14
   ΦΠΑ=0.21
   ΒΑΣΗ=10



Στατική δομή δεδομένων: Δομή δεδομένων της οποίας το μέγεθος προκαθορίζεται τη στιγμή δήλωσής της και αποθηκεύεται σε συνεχόμενες θέσεις μνήμης.

Παράδειγμα: Πίνακας.




Στοίβα (Stack): Δυναμική δομή δεδομένων με ένα άκρο, στην οποία το τελευταίο στοιχείο που εισάγεται είναι το πρώτο που μπορεί να εξαχθεί. Λειτουργίες της είναι η ώθηση (push) και η απώθηση (pop).

Οι λειτουργίες της δομής δεδομένων στοίβα.
Οι λειτουργίες της δομής δεδομένων στοίβα.




Μια στοίβα από βιβλία.
Μια στοίβα από βιβλία.






Περισσότερα



Συγχώνευση (Merging): Λειτουργία συνδυασμού δύο ταξινομημένων όμοιων δομών δεδομένων προς δημιουργία μιας καινούργιας μεγαλύτερης ταξινομημένης δομής που θα περιλαμβάνει τα στοιχεία και των δύο.

Συγχώνευση ταξινομημένων πινάκων.
Συγχώνευση ταξινομημένων πινάκων.


Παράδειγμα: Κώδικας σε ΓΛΩΣΣΑ για τη συγχώνευση ταξινομημένων κατά αύξουσα σειρά πινάκων ακεραίων Α[5], Β[7] προς δημιουργία του ταξινομημένου πίνακα Μ[12]:
.......
i←0
j←0
k←0
ΟΣΟ (i<5) KAI (j<7) EΠΑΝΑΛΑΒΕ
   ΑΝ A[i] < B[j] TOTE                (Σύγκρίνε τα μικρότερα στοιχεία του πίνακα μεταξύ τους)
      M[k]←A[i]                       (Και βάλε το μικρότερο στο νέο πίνακα)
      k←k+1                           (Ενημέρωσε κατάλληλα τους δείκτες των πινάκων)
      i←i+1
   AΛΛΙΩΣ
      M[k]←B[j]
      k←k+1
      j←j+1
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ                     (Όταν τελειώσει ένας εκ των 2 πινάκων)
ΑΝ i<5 TOTE
   ΓΙΑ λ ΑΠΟ k ΕΩΣ 11                (Αντίγραψε τα στοιχεία του άλλου πίνακα στον πίνακα συγχώνευσης)
     Μ[λ]←Α[i]
     i←i+1
   TΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΛΛΙΩΣ
   ΓΙΑ λ ΑΠΟ k ΕΩΣ 11
     Μ[λ]←Β[j]
     j←j+1
   TΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΑΝ
......
 




Συμβολική γλώσσα (Assembly language): Γλώσσα προγραμματισμού χαμηλού επιπέδου, εξαρτώμενη από την αρχιτεκτονική του εκάστοτε υπολογιστή. Αποτελεί συμβολική αναπαράσταση του δυαδικού κώδικα της γλώσσας μηχανής και χρειάζεται συμβολομετάφραση.
symbolic.JPG
Παράδειγμα εντολών συμβολικής γλώσσας που αντιστοιχούν σε μια εντολή ανάθεσης.

external image PROG-LAN.gif
Περισσότερα για τις συμβολικές γλώσσες




Συμβολομεταφραστής (Assembler): Πρόγραμμα που μεταφράζει τη συμβολική γλώσσα σε γλώσσα μηχανής του δεδομένου υπολογιστή.

Περισσότερα




Συνάρτηση: Τύπος υποπρογράμματος με περιορισμένες δυνατότητες (σε αντίθεση με τη διαδικασία). Σκοπός του είναι ο υπολογισμός μιας τιμής που επιστρέφεται στο πρόγραμμα που την κάλεσε.

Παράδειγμα: Συνάρτηση υπολογισμού απόλυτης τιμής σε ΓΛΩΣΣΑ.
ΣΥΝΑΡΤΗΣΗ ΑΠΟΛΥΤΗ_ΤΙΜΗ(Χ): ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
   ΠΡΑΓΜΑΤΙΚΕΣ: Χ
ΑΡΧΗ ΑΝ Χ=0 ΤΟΤΕ
   ΑΠΟΛΥΤΗ_ΤΙΜΗ←Χ
ΑΛΛΙΩΣ
   ΑΠΟΛΥΤΗ_ΤΙΜΗ←(-1)*Χ
ΤΕΛΟΣ_ΣΥΝΑΤΗΣΗΣ




Συνδέτης-φορτωτής (Linker-loader): Το πρόγραμμα που που συνδέει το αντικείμενο πρόγραμμα με τμήματα προγράμματος από τις βιβλιοθήκες της γλώσσας προγραμματισμού, προς δημιουργία του εκτελέσιμου προγράμματος.
metaglwtisi2.JPG
Δημιουργία εκτελέσιμου προγράμματος από το συνδέτη-φορτωτή με χρήση βιβλιοθηκών.


Περισσότερα




Συνθήκη: Μια έκφραση σε ένα πρόγραμμα που με βάση την αποτίμησή της σε αληθή ή ψευδή, καθορίζεται η ροή του προγράμματος.

Παραδείγματα: Συνθήκες : ONOMA <> 'ΜΑΡΙΑ', T==1.
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ ΟΝΟΜΑ, ΕΠΙΘΕΤΟ
ΜΕΧΡΙΣ_ΟΤΟΥ ΟΝΟΜΑ<>'ΜΑΡΙΑ'
 

Τ←1
Ρ←1
ΟΣΟ Τ==1 ΕΠΑΝΑΛΑΒΕ
  ΓΡΑΨΕ 'ΑΛΛΗ ΜΙΑ ΕΠΑΝΑΛΗΨΗ'
  Ρ←Ρ+1
  ΑΝ Ρ==10 ΤΟΤΕ
     Τ←0
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ





Συντάκτης (Editor): Το πρόγραμμα που χρησιμοποιείται για τη σύνταξη και τη διόρθωση του κώδικα ενός προγράμματος.
Συντάκτης της ΓΛΩΣΣΑΣ.
Συντάκτης της ΓΛΩΣΣΑΣ.





Σφάλμα (Bug): Λάθος στον κώδικα του προγράμματος.




SQL: Γλώσσα ερωταπαντήσεων της δεκαετίας του 80 με χρήση στις βάσεις δεδομένων.

Παράδειγμα: Κώδικας SQL.

sql.JPG

Περισσότερα