Έψιλον:



εισαγωγή, εισαγωγή, είσοδος, εκτελέσιμο, έκφραση, εκχώρηση, εμφώλευση, εντολή, εξαγωγή, έξοδος, επανάληψη, επεξεργασία, επιλύσιμο, επιστρεφόμενη τιμή, εφαρμογή




Εισαγωγή: Πρώτη σημασία (Enqueue): Λειτουργία της δομής δεδομένων ουρά, με την οποία γίνεται προσθήκη ενός νέου στοιχείου στο πίσω άκρο της ουράς.




Εισαγωγή: Δεύτερη σημασία: Βασική λειτουργία των δομών δεδομένων εν γένει, με την οποία γίνεται προσθήκη νέου στοιχείου στη δομή με κατάλληλο τρόπο.




Είσοδος αλγορίθμου (Input): Τα που δίνονται προς επεξεργασία στον αλγόριθμο.
eisodos_exodos.JPG




Εκτελέσιμο πρόγραμμα (Executable): Το τελικό πρόγραμμα που εκτελείται από τον υπολογιστή. Παράγεται μετά τη σύνδεση του αντικείμενου προγράμματος με τις βιβλιοθήκες της γλώσσας μέσω του συνδέτη-φορτωτή.
metaglwtisi2.JPG
Δημιουργία εκτελέσιμου προγράμματος από το συνδέτη με χρήση βιβλιοθηκών.


Περισσότερα




Έκφραση (Exression): Μια έκφραση αποτελείται από τους τελεστέους (σταθερές και μεταβλητές) και τους τελεστές (σύμβολα που εκφράζουν μια πράξη). Η διεργασία αποτίμησης μιας έκφρασης συνίσταται στην απόδοση τιμών στις μεταβλητές και την εκτέλεση των πράξεων σύμφωνα με την προτεραιότητα των τελεστών και την ενδεχόμενη χρήση παρενθέσεων.
Παράδειγμα: Εκφράση στη ΓΛΩΣΣΑ:
((x + y^2 +5*z + 12)*(7+3*y) > 0) ΚΑΙ ((x^2 + y -8*z)>10) KAI ((x^8>y^8)H (x^7>z^5))




Εκχώρηση (Assignment): Μηχανισμός απόδοσης τιμής σε μια μεταβλητή.
Παράδειγμα: Εκχώρηση στη ΓΛΩΣΣΑ: (όπου η x,a,b είναι ακέραιeς μεταβλητές).
x ← 32

x ← a*b+132




Εμφωλευμένη (Nested) διαδικασία: Η τοποθέτηση μιας δομής εντολών αλγορίθμου (επιλογής ή επανάληψης) μέσα σε μια άλλη δομή του ίδιου τύπου.

Παράδειγμα: Εμφωλευμένες δομές επιλογής στη ΓΛΩΣΣΑ, όπου η Χ είναι ακέραια μεταβλητή.
ΑΝ Χ>0 ΤΟΤΕ
   ΑΝ X MOD 2==0 TOTE
      ΓΡΑΨΕ 'Ο Χ ΕΙΝΑΙ ΘΕΤΙΚΟΣ ΑΡΤΙΟΣ'
   ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Ο Χ ΕΙΝΑΙ ΘΕΤΙΚΟΣ ΠΕΡΙΤΤΟΣ'
   ΤΕΛΟΣ_ΑΝ
ΑΛΛΙΩΣ
   ΑΝ Χ<0 ΤΟΤΕ
       ΑΝ X MOD 2==0 TOTE
          ΓΡΑΨΕ 'Ο Χ ΕΙΝΑΙ ΑΡΝΗΤΙΚΟΣ ΑΡΤΙΟΣ'
       ΑΛΛΙΩΣ
          ΓΡΑΨΕ 'Ο Χ ΕΙΝΑΙ ΑΡΝΗΤΙΚΟΣ ΠΕΡΙΤΤΟΣ'
       ΤΕΛΟΣ_ΑΝ
   ΑΛΛΙΩΣ
       ΓΡΑΨΕ 'Ο Χ ΕΙΝΑΙ ΜΗΔΕΝ'
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΑΝ
Παράδειγμα: Εμφωλευμένες επαναλήψεις στη ΓΛΩΣΣΑ, οπου ο Α είναι πίνακας ακεραίων και η Ζ ακέραια μεταβλητή.
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ n-1
    ΓΙΑ j ΑΠΟ i+1 ΜΕΡΧΙ n
          Ζ←Α[i]*A[j]
          ΓΡΑΨΕ Ζ
Παράδειμα εμφωλευμένων αντικειμένων.
Παράδειμα εμφωλευμένων αντικειμένων.





Εντολή (Instruction): Έκφραση σύμφωνη με το συντακτικό μια γλώσσας προγραμματισμού που εκφράζει μια πράξη που πρέπει να εκτελέσει ένα πρόγραμμα.

Παράδειγμα σε ΓΛΩΣΣΑ: ΔΙΑΒΑΣΕ Χ, ΓΡΑΨΕ ''ΚΑΛΗΜΕΡΑ ΚΟΣME"'.




Εξαγωγή (Dequeue): Λειτουργία της δομής ουρά, που εξάγει στοιχείο από το εμπρός άκρο της ουράς.




Έξοδος αλγορίθμου (Output): Τα αποτελέσματα της εκτέλεσης του αλγορίθμου.




Επανάληψη (Iteration): Η επαναλαμβανόμενη εκτέλεση μιας ομάδας εντολών απο ένα πρόγραμμα με βάση την ικανοποίηση κάποιας συνθήκης.




Επεξεργασία δεδομένων (Data processing): Διαδικασία κατά την οποία ένας "μηχανισμός" δέχεται δεδομένα, τα επεξεργάζεται με βάση έναν προκαθορισμένο τρόπο και εξάγει πληροφορίες.
epexergasia.JPG
Εξαγωγή πληροφορίας.





Επιλύσιμο πρόβλημα: Πρόβλημα για το οποίο υπάρχει ήδη γνωστός αλγόριθμος που δίνει τη λύση του.

Παράδειγμα: Υπολογισμός μέγιστου κοινού διαιρέτη δύο ακεραίων αριθμών (αλγόριθμος του Ευκλείδη).




Επιστρεφόμενη τιμή: Η τιμή που υπολογίζεται από μια συνάρτηση και επιστρέφεται στο καλόν πρόγραμμα.

Παράδειγμα σε ΓΛΩΣΣΑ: η επιστρεφόμενη τιμή που επιστέφεται στο όνομα της συνάρτησης είναι η τιμή του εμβαδού του τριγώνου.
ΣΥΝΑΡΤΗΣΗ ΕΜΒΑΔΟ_ΤΡΙΓΩΝΟΥ(Β,Υ): ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
   ΠΡΑΓΜΑΤΙΚΕΣ: Β,Υ
ΑΡΧΗ
   ΕΜΒΑΔΟ_ΤΡΙΓΩΝΟΥ←(Β*Υ)/2
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ




Εφαρμογή (Αpplication): Πρόγραμμα που έχει δημιουργηθεί για την κάλυψη μιας συγκεκριμένης ανάγκης.

Παράδειγμα: Προγράμματα αναπαραγωγής μουσικής.